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Q1 Define Computer? 

A1 Definition of Computer 

A computer is an electronic device that processes data, following a set of instructions to perform 

tasks such as calculations, data storage, retrieval, and communication. 

 

Q2. Describe the brief history of Computer Development? 

Or  

Q3. Describe the various generations of Computer Development? 

Ans2 & 3 : Brief History of Computer Development 

 



 

 

 

The development of computers can be divided into several key generations: 

1. First Generation (1940-1956) - Vacuum Tubes: Early computers used vacuum tubes for 

circuitry and magnetic drums for memory. They were enormous, consumed a lot of power, 

and generated heat. An example is the ENIAC. 

2. Second Generation (1956-1963) - Transistors: Transistors replaced vacuum tubes, 

making computers smaller, faster, cheaper, and more energy-efficient. IBM 1401 is an 

example of a second-generation computer. 

3. Third Generation (1964-1971) - Integrated Circuits: Integrated circuits (ICs) replaced 

transistors, allowing for smaller and more powerful machines. These computers could perform 

multiple tasks simultaneously. An example is the IBM System/360. 

4. Fourth Generation (1971-Present) - Microprocessors: Microprocessors placed the 

entire CPU on a single chip, drastically reducing the size and cost of computers. This 

generation saw the rise of personal computers (PCs), with Apple II and IBM PC being 

prominent examples. 

5. Fifth Generation (Present and Beyond) - Artificial Intelligence: This generation 

focuses on the use of artificial intelligence (AI) to develop computers that can process natural 

language, make decisions, and solve complex problems. Technologies like quantum computing 

and machine learning are emerging in this era. 

 

Q4 Draw block diagram of computer? 

A4 Block Diagram of a Computer 

 

 

 



 

 

A basic computer block diagram includes the following components: 

• Input Unit: The unit which feed data and instructions in the computer system e.g Keyboard, 

Mouse, Scanner, Camera etc. 

• Output Unit: The unit which displays or stores the result e.g. Monitor, Printer, Plotter etc. 

• CPU (Central Processing Unit): The brain of the computer, which includes: 

o ALU (Arithmetic and Logic Unit): Performs mathematical and logical operations. 

o Control Unit (CU): Directs the operation of all components. 

• Memory: Stores data and instructions temporarily (RAM) or permanently (ROM). 

• Storage Unit: Secondary storage like hard drives, SSDs, etc. 

 

Q5 What is Hardware & Software in Computer? 

A5 Hardware vs. Software 

 

• Hardware refers to the physical components of a computer (e.g., CPU, RAM, keyboard, 

mouse). 

• Software refers to the programs and instructions that direct the computer’s hardware to 

perform tasks (e.g., operating systems, applications). 

 



 

 

Q6 What is Booting? What are its types? 

A6 Booting 

 

Booting is the process of starting a computer and loading the operating system into memory. 

• Cold Booting: Turning on a computer from a powered-off state. 

• Hot Booting: Restarting a computer without turning it off completely. 

 

 

Q7 How the Input/Output devices interact with CPU/Memory Unit? 

A7 Interaction between CPU, Memory, and I/O Devices 

 

 



 

 

• CPU and Memory: The CPU fetches data and instructions from the memory (RAM) for 

processing. The memory holds data temporarily and transfers it to the CPU as needed. 

• CPU and Input/Output (I/O) Devices: The CPU communicates with I/O devices via input 

(keyboard, mouse) and output (monitor, printer). It sends processed data to the output 

devices and receives input data through the input devices. 

 

Q8 What are the functions of CPU and its Major Functional Parts? 

A8 Function of the CPU and its Major Functional Parts 

 

• CPU: The Central Processing Unit is responsible for executing instructions, performing 

calculations, and managing data flow within the computer. 

o ALU (Arithmetic and Logic Unit): Handles mathematical operations and logical 

comparisons. 

o Control Unit (CU): Directs the CPU’s operations, telling other components how 

to respond to program instructions. 

o Registers: Hold small amounts of data temporarily for quick access by the CPU. 

 

Q9 What is memory unit in computer? Describe the various units of Memory? 

A9 Memory 

 



 

 

• Memory is where a computer stores data and instructions for immediate use. 

o Bit: Smallest unit of data (0 or 1). 

o Nibble: 4 bits. 

o Byte: 8 bits. 

o Kilobyte (KB): 1,024 bytes. 

o Megabyte (MB): 1,024 KB. 

o Gigabyte (GB): 1,024 MB. 

o Terabyte (TB): 1,024 GB. 

o Petabyte (PB): 1,024 TB. 

 

Q 10 What are the functions of various memory units? 

A 10 Functions of Memory 

 

• RAM (Random Access Memory): Temporarily stores data and instructions for quick 

access by the CPU. 

• ROM (Read-Only Memory): Permanently stores essential instructions like bootloader 

firmware. 

• Cache Memory: A smaller, faster type of memory located near the CPU to speed up data 

access for frequently used information. 

 

 

 

 

 

 



 

 

Q 11 Describe the use of storage devices in a computer? 

A 11 Use of Storage Devices in a Computer 

 

Storage devices (e.g., HDDs, SSDs, USB drives) provide long-term data storage, retaining information 

even when the computer is powered off. They store operating systems, software applications, and 

user data. 

 

Q 12 Describe Primary Memory, Secondary Memory & Cache Memory? 

A 12 Types of Memory Used in a Computer 

 

•  



 

 

• Primary Memory: Includes RAM and ROM, used for immediate data access. 

• Secondary Memory: Includes HDDs, SSDs, and optical drives, used for long-term data 

storage. 

• Cache Memory: High-speed memory close to the CPU for fast data access. 

 

Q 13 Describe the importance of Cache Memory in Computer? 

A 13 Importance of Cache Memory 

Cache memory is essential because it stores frequently accessed data and instructions, reducing the 

time the CPU takes to retrieve them from slower RAM. This improves overall system performance. 

 

Q14 Describe CPU Speed and Word Length? 

A 14 CPU Speed and Word Length 

• CPU Speed: Measured in GHz (gigahertz), it indicates how many cycles per second the CPU 

can execute, determining the speed of processing. 

• CPU Word Length: Refers to the number of bits the CPU can process at a time, typically 

32-bit or 64-bit. A higher word length allows the CPU to handle more data in each cycle, 

increasing efficiency. 
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Q1 Describe the Overview of Basic Internet Skills? 

A1 Basic Internet Skills Overview 

 

Internet is a global network that connects millions of computers worldwide, enabling users to share 
and access information, communicate, and collaborate. Mastering basic internet skills involves 
understanding how to use web browsers, search engines, and various online communication tools 
effectively. 

 

Q2 Name various Web Browser 

A2 Understanding Browsers 



 

 

 

A web browser is software used to access and navigate the World Wide Web (WWW). Popular 
web browsers include: 

• Google Chrome 

• Mozilla Firefox 

• Microsoft Edge 

• Safari 

• Microsoft Internet Explorer 

Q3 What are the basic functions of Web Browser 

A3 Basic Browser Functions: 

• Address Bar: Enter website URLs. 

• Tabs: Open multiple websites simultaneously. 

• Bookmarks: Save frequently visited websites. 

• History: View previously visited websites. 

 

Q4 Write a short note on WWW 

A4 Introduction to WWW (World Wide Web) 



 

 

 

The World Wide Web (WWW) is a system of interlinked hypertext documents and multimedia 
content, accessed via the internet. The WWW allows users to browse websites, interact with 
multimedia, and access services such as email and online banking. 

 

 

Q5 What is Search Engine?  

A5 A search engine is a tool that helps users find information on the internet. Common search 
engines include: 



 

 

 

• Google 

• Bing 

• Yahoo 

Q6 Give few tips for Efficient Searching 

A6 Tips for Efficient Searching: 

1. Use Specific Keywords: Instead of general terms, use specific phrases (e.g., “best laptop for 
students”). 

2. Use Quotation Marks (""): To search for exact phrases (e.g., “cloud computing basics”). 

3. Use Boolean Operators: Combine keywords with operators like AND, OR, and NOT 
(e.g., "AI AND education"). 

4. Use Advanced Search Options: Filters like time, location, or file type. 

 

Q7 Write short note on Digital India Portals? 

A7 Digital India Portals 



 

 

 

The Digital India initiative aims to transform India into a digitally empowered society. Key national 
and state portals include: 

• National Portals: 

o MyGov.in: A citizen engagement platform. 

o Digital India Portal: Provides access to government services online. 

o UMANG App: Unified Mobile Application for New-age Governance. 

• State Portals: Each state has specific portals for e-governance, providing services like land 
records, tax payments, and certificates. 

• College Portals: Educational institutions provide portals for student management, access to 
academic resources, examination results, and communication with faculty. 

 

Q8 Expand E-mail? What are the advantages of E-mail? 

A8 E-mail stands for Electronic Mail. 

 

Advantages of Email 

Email is a quick, efficient, and cost-effective communication tool. Advantages include: 

• Speed: Instant delivery of messages globally. 

• Documentation: Provides a written record of communication. 



 

 

• Attachment of Files: Documents, images, and files can be shared. 

• Accessibility: Emails can be accessed from anywhere via the internet. 

 

Q9 Name various Email Service Providers 

A9 Various Email Service Providers 

 

Popular email service providers include: 

• Gmail (Google) 

• Outlook (Microsoft) 

• Yahoo Mail 

• Proton Mail (for encrypted emails) 

 

Q 10 Name the steps involved in creating an Email ID, Sending and Receiving Emails? 

A10 Steps involved in Creating an Email ID, Sending and Receiving Emails 

 



 

 

To create an email account: 

1. Choose a provider (e.g., Gmail). 

2. Visit the provider’s website and select Create Account. 

3. Fill in personal details (name, username, password, etc.). 

4. Verify the account via mobile number or secondary email. 

Sending and Receiving Emails: 

• To send an email: Compose a new email, enter the recipient’s address, type the message, 
and click Send. 

• Receiving Emails: Incoming emails are received in your Inbox. 

 

Q11 How to attach documents with Emails and Drive 

A11 Attaching Documents with Emails and Drive 

 

 

 

• To attach documents in emails, click on the Attach Files icon (usually a paperclip) and 
select files from your computer. 

• For large files, use cloud storage services like Google Drive. You can insert Google Drive 
links in your email by clicking on the Google Drive icon in Gmail. 

 

 



 

 

 

Q12 Describe the effective use of Gmail, G-Drive, Google Calendar, Google Sites and 
Google Sheets? 

A12 Effective Use of Gmail, G-Drive, Google Calendar, Google Sites, and Google Sheets 

1. Gmail: 

o Filters: Organize emails by setting up rules. 

o Labels: Categorize emails for easy access. 

o Gmail Labs: Experimental features for enhanced productivity. 

2. Google Drive: 

o Cloud Storage: Store and share files securely online. 

o Collaboration: Share files with others and work on them in real-time. 

3. Google Calendar: 

o Event Scheduling: Set reminders for meetings, deadlines, and events. 

o Sharing: Share your calendar with others to coordinate schedules. 

4. Google Sites: 

o Website Creation: Easily create websites for personal, academic, or business use 
without programming knowledge. 

o Collaboration: Multiple users can work on a site together. 

5. Google Sheets: 

o Spreadsheets: Create, edit, and share spreadsheets online. 

o Data Analysis: Perform calculations, create charts, and visualize data. 

 

Q 11 Describe the video conferencing tools for communications? 

A11 Online Mode of Communication Using Google Meet & WebEx 



 

 

 

• Google Meet: 

o Free video conferencing platform integrated with Google services. 

o Users can schedule meetings via Google Calendar and share links with participants. 

o It allows screen sharing, recording, and real-time collaboration through Google Docs. 

• WebEx: 

o A professional video conferencing tool used for online meetings, webinars, and 
presentations. 

o It supports features like screen sharing, breakout rooms, chat, and document sharing. 
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Q1 Describe the Basic Logic Building in Programming 

 

A1 Logic building in programming refers to developing a clear thought process to solve a problem 
step by step. The goal is to use logical steps that a computer can execute to reach a desired outcome. 

 

Q2 Describe the Introduction to Programming 



 

 

A2  

 Programming is the process of designing and writing instructions that a computer can follow to 
perform specific tasks. A program is a collection of these instructions written in a programming 
language like Python, Java, or C++. The process of programming involves several steps, including 
problem analysis, designing algorithms, coding, and debugging. 

 

Q3 Describe the Steps Involved in Problem Solving 

A3 Steps involved are:  

 

1. Understand the Problem: Analyze the problem thoroughly, understanding the inputs, 
desired outputs, and any constraints. 

2. Plan a Solution (Algorithm): Break the problem into logical steps, which can be executed 
by the computer. 

3. Design a Flowchart: Visualize the steps of the solution using diagrams. 

4. Write the Program (Code): Translate the algorithm into a specific programming language. 



 

 

5. Test and Debug: Run the program to check if it produces the correct result and fix any 
errors (bugs). 

6. Optimize the Solution: Ensure the program is efficient, readable, and maintains good 
performance. 

 

Q4 Definition of Algorithm 

 

A4   

An algorithm is a step-by-step procedure for solving a problem. It is a logical sequence of actions to 
be performed to achieve a specific goal. An algorithm must be: 

• Clear and unambiguous. 

• Stepwise: Each step should be precise. 

• Finite: Must have a clear endpoint. 

Example of an Algorithm (for adding two numbers): 

1. Start 

2. Input number1 

3. Input number2 

4. Add number1 and number2 

5. Output the result 

6. End 

 



 

 

Q5 Definition of Flowchart 

A5  

 A flowchart is a graphical representation of an algorithm. It uses various symbols to depict the flow 
of control or data in a process. 

 

Q6 Write down the Steps Involved in Algorithm Development 

A6 Steps are  

1. Problem Identification: Clearly understand what the problem is and what the desired 
outcome should be. 

2. Input/Output Identification: Determine what inputs are required and what outputs need 
to be generated. 

3. Design Logic (Steps): Break the problem into small, executable steps. 

4. Error Handling: Plan for possible errors or edge cases. 

5. Testing: Test the algorithm with various inputs to ensure correctness. 

 

Q7 Difference Between Algorithm and Flowchart 



 

 

A7 Algorithm Flowchart 

Step-by-step textual representation of a 
process. 

Pictorial/diagrammatic representation of a process. 

Focuses on logic and sequence of steps. Focuses on flow of control and data. 

Easier to write but harder to visualize. 
Easier to understand visually but requires correct 
symbols. 

Language independent and more abstract. Relies on standard symbols for communication. 

 

Q8 What are the Symbols Used in Flowcharts 

A8 

 

• Oval (Start/End): Represents the beginning or end of a process. 

• Parallelogram (Input/Output): Indicates an input (data input) or output (display result). 

• Rectangle (Process): Represents a process or instruction. 

• Diamond (Decision): Represents a decision point, where the flow branches based on a 
condition (Yes/No or True/False). 

• Arrow (Flow Line): Indicates the direction of flow of control. 

 

Q9 Write Algorithms for Simple Problems 

A9  



 

 

Example 1: Algorithm to Find the Largest of Two Numbers: 

1. Start 

2. Input number1 

3. Input number2 

4. If number1 > number2, print "number1 is largest" 

5. Else, print "number2 is largest" 

6. End 

Example 2: Algorithm to Check if a Number is Even or Odd: 

1. Start 

2. Input number 

3. If number % 2 == 0, print "Even" 

4. Else, print "Odd" 

5. End 

 

Flowcharts for Simple Problems 

Example 1: Flowchart for Finding the Largest of Two Numbers 

• Start (Oval) 

• Input number1, Input number2 (Parallelogram) 

• Decision: Is number1 > number2? (Diamond) 

o If Yes: Print "number1 is largest" (Parallelogram) 

o If No: Print "number2 is largest" (Parallelogram) 

• End (Oval) 

Example 2: Flowchart for Checking if a Number is Even or Odd 

• Start (Oval) 

• Input number (Parallelogram) 

• Decision: Is number % 2 == 0? (Diamond) 

o If Yes: Print "Even" (Parallelogram) 

o If No: Print "Odd" (Parallelogram) 

• End (Oval) 

 

Practice Logic Building Using Flowcharts/Algorithms 

To build your programming logic, practice developing flowcharts and algorithms for common tasks, 
such as: 



 

 

• Finding the sum of an array of numbers. 

• Calculating the factorial of a number. 

• Finding the greatest common divisor (GCD) of two numbers. 

Practice Example: Algorithm to Find the Sum of Two Numbers 

1. Start 

2. Input number1 

3. Input number2 

4. sum = number1 + number2 

5. Print sum 

6. End 

Flowchart: 

• Start (Oval) 

• Input number1, Input number2 (Parallelogram) 

• Process: sum = number1 + number2 (Rectangle) 

• Output sum (Parallelogram) 

• End (Oval) 

Practicing these helps in developing the fundamental logic needed to create efficient programs in any 
language. 
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Q1 Office Tools: LibreOffice, OpenOffice, and MS Office 

A1 Office Tools are software suites designed to help users create and manage documents, 
spreadsheets, and presentations. Popular office tools include: 

• LibreOffice: Free, open-source office suite compatible with various formats. 

• OpenOffice: Another open-source suite, similar to LibreOffice. 

• MS Office: A proprietary suite from Microsoft that includes tools like Word, Excel, and 
PowerPoint. 

 

Q2 OpenOffice Writer (Word Processor) 

A2 OpenOffice Writer is the word processing component of the OpenOffice suite, similar to MS 
Word or LibreOffice Writer. 

Key Functions in OpenOffice Writer: 

1. Typesetting Text and Basic Formatting: 

o Typesetting involves adjusting the text for clarity and appearance. Basic text 
formatting tools include: 

▪ Bold, Italic, Underline 

▪ Font Type and Size 

▪ Alignment (Left, Center, Right, Justify) 

▪ Line Spacing 

o These can be accessed from the toolbar or through the Format menu. 

2. Inserting Images: 

o Insert > Picture > From File: Allows you to insert an image from your computer. 

o You can also resize, align, and add captions to images after insertion. 

3. Inserting Hyperlinks: 

o Select text or image > Insert > Hyperlink: Link text or an image to a URL, email, 
or document. 

4. Bookmarks: 

o Insert > Bookmark: Mark specific locations in the document for quick navigation. 

5. Inserting Tables and Table Properties: 

o Table > Insert Table: Create tables to organize data. 

o Customize tables using Table Properties (adjust column widths, row heights, 
borders, and background colors). 

 

LibreOffice/OpenOffice Calc (Spreadsheet Tool) 



 

 

Calc is the spreadsheet component of LibreOffice and OpenOffice, similar to MS Excel. It's used for 
managing data, performing calculations, and visualizing data using charts. 

Key Functions in Calc: 

1. Working with Cells: 

o Select Cells: Click on individual cells or drag to select a range. 

o Insert/Delete Cells: Right-click a cell to insert or delete rows/columns. 

o Format Cells: Use Format > Cells to set number formats (e.g., currency, 
percentage) or apply borders, backgrounds, and alignment. 

2. Working with Sheets: 

o Add/Remove Sheets: Manage multiple sheets by clicking the + at the bottom or 
using Insert > Sheet. 

o Rename Sheets: Right-click the sheet tab and select Rename. 

3. Working with Data and Tables: 

o Sort Data: Use Data > Sort to sort data in ascending or descending order. 

o Filter Data: Use Data > Filter to apply filters for easier data management. 

4. Using Formulae and Functions: 

o Formulas: Start with = to write formulas (e.g., =A1+B1). 

o Functions: Use built-in functions such as SUM, AVERAGE, IF, etc. Access functions 
using Insert > Function. 

5. Using Charts and Graphics: 

o Insert > Chart: Create charts (e.g., bar, line, pie) to visualize data. 

o You can customize chart properties, such as labels, colors, and axis titles. 

 

OpenOffice Impress (Presentation Tool) 

Impress is the presentation software in OpenOffice, similar to Microsoft PowerPoint and LibreOffice 
Impress. It is used to create slideshows with text, images, and animations. 

Key Functions in Impress: 

1. Creating and Viewing Presentations: 

o File > New > Presentation: Start a new presentation. 

o You can view slides in different modes (Normal, Outline, Notes, and Slide Sorter) 
using the View menu. 

2. Inserting Pictures and Tables: 

o Insert > Picture > From File: Add images to slides. 

o Insert > Table: Insert tables to organize information on slides. 

3. Slide Master and Slide Design: 



 

 

o Slide Master: Allows you to set a consistent layout, font, and design across multiple 
slides. Access via View > Master > Slide Master. 

o Slide Design: Predefined slide designs can be selected under Format > Slide 
Design. You can apply backgrounds, colors, and layout templates. 

4. Custom Animation: 

o Custom Animation: Apply animations to text, images, and objects on your slides. 
Go to Slide Show > Custom Animation to set animation effects, timing, and 
transitions. 
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Q1 Describe the Use of Social Media & Digital Marketing 

A1 Social Media  

 

has revolutionized the way people connect, share information, and market products and services. It is 
not just a platform for personal use but is also essential for businesses and digital marketers to engage 
with audiences. 

 

Q2 Introduction to Digital Marketing 

A2 

  

Digital Marketing is the use of digital platforms, the internet, and other online channels to promote 
products and services. It encompasses various online marketing strategies like SEO (Search Engine 
Optimization), SEM (Search Engine Marketing), social media marketing, email marketing, and content 
marketing. 



 

 

Q3 Why Digital Marketing? 

A3 

 

• Wider Audience Reach: Digital marketing allows businesses to reach a global audience. 

• Cost-effective: Compared to traditional marketing, digital marketing is more affordable and 
can yield higher ROI (Return on Investment). 

• Targeted Marketing: Through tools like Google Ads or Facebook Ads, businesses can 
target specific demographics based on age, location, interests, etc. 

• Measurable Results: Digital marketing campaigns can be tracked and measured in real-time, 
allowing for adjustments and optimization. 

• Customer Engagement: Digital marketing allows direct interaction with customers, making 
it easier to build brand loyalty. 

Q4 What are the Characteristics of Digital Marketing 

A4  



 

 

 

1. Interactivity: Two-way communication between businesses and consumers. 

2. Personalization: Ability to personalize marketing messages based on customer preferences. 

3. Global Reach: Digital platforms allow marketing campaigns to extend beyond local borders. 

4. Real-Time Results: Analytics and data can be tracked instantly, allowing businesses to 
measure success and adjust strategies. 

 

 

Q5 What are the Tools for Digital Marketing 

A5 



 

 

 

1. Google Analytics: Tracks website traffic and user behavior. 

2. Google Ads: For pay-per-click (PPC) advertising. 

3. SEMrush: For keyword research, SEO audits, and competitive analysis. 

4. Mailchimp: For email marketing campaigns. 

5. Hootsuite/Buffers: For managing multiple social media accounts and scheduling posts. 

 

Q6 Write Effective Use of Social Media 

A6  

 

Social media platforms are integral to digital marketing strategies. Here's how some of the most 
popular platforms can be used effectively for both personal and business purposes: 

LinkedIn 

• Professional Networking: LinkedIn is primarily used for building professional relationships, 
finding jobs, and connecting with industry peers. 

• Company Pages: Businesses can create company pages to showcase products and services, 
share updates, and recruit talent. 

• Content Sharing: Articles, blog posts, and industry insights are often shared to establish 
expertise and build a personal brand. 

Facebook 



 

 

• Business Pages: Businesses can create pages to engage with followers, post updates, and 
promote products. 

• Facebook Ads: Offers highly targeted advertising based on demographics, interests, and 
behavior. 

• Groups and Communities: Businesses can create or join groups to engage with niche 
audiences or customers. 

Twitter 

• Real-Time Engagement: Twitter is a platform for quick updates, news, and interaction. It’s 
often used for real-time customer support. 

• Hashtags: Using hashtags allows posts to be found by users interested in specific topics or 
trends. 

• Promoted Tweets: Businesses can boost tweets to increase visibility to a larger audience. 

Google+ (Discontinued in 2019) 

Google+ was used for personal and professional networking, but it has since been discontinued by 
Google due to low usage. 

 

Q7 Write the Features of Social Media 

A7  



 

 

 

Features of Social Media: 

• Connectivity: Social media allows users to connect with people globally. 

• User-Generated Content: Anyone can create and share content, whether text, images, 
videos, or articles. 

• Real-Time Communication: Instant messaging, commenting, and live features enable real-
time interaction. 

• Multimedia Sharing: Users can share photos, videos, and audio seamlessly. 

• Targeted Advertising: Social media platforms offer advanced tools for targeting specific 
groups based on their interests, location, age, and more. 

 

Q What are the Advantages of Social Media 

A  



 

 

 

1. Brand Awareness: Social media increases visibility for individuals and businesses. 

2. Direct Customer Interaction: Businesses can interact with customers, resolve queries, 
and receive feedback in real time. 

3. Cost-Effective Marketing: Social media marketing is often cheaper than traditional methods 
like TV ads or billboards. 

4. Content Sharing: Social media makes it easy to share articles, videos, and photos, driving 
traffic to websites or blogs. 

5. Analytics: Built-in analytics tools help measure the success of marketing campaigns and track 
engagement. 

 

Disadvantages of Social Media 

1. Time-Consuming: Managing multiple social media accounts and responding to user 
engagement can be time-intensive. 

2. Negative Feedback: Public platforms expose brands to negative reviews and criticism, 
which can harm reputation. 

3. Privacy Concerns: Sharing personal information online can lead to data breaches, identity 
theft, and other privacy issues. 

4. Misinformation: Social media can spread misinformation and fake news rapidly. 



 

 

5. Addiction: Social media platforms can lead to compulsive usage, impacting productivity and 
well-being. 

 



Computer  Questions 
Q :   
Which of the following is not an example of an input device? 

(A) Keyboard 

(B) Mouse 

(C) OMR 

(D) Monitor 

Hide Answer 
 
Correct Answer: D 
 

Q :   
What are the two types of output devices? 
(A) Monitor printer 

(B) Windows 2000 and Windows NT 

(C) Keyboard mouse 

(D) Storage disk and floppy 

Hide Answer 
 
Correct Answer : A 
 

Q :   
What is the full name of PC? 
(A) Public Computer 

(B) Personal Computer 

(C) Private Computer 

(D) Both (B) and (C) 

Hide Answer 
 
Correct Answer: B 
 

Q :   
DVD is an example of? 
(A) Output device 

(B) Hard Disk 

(C) Optical disc 

(D) Object disc 

Hide Answer 
 
Correct Answer : C 



Explanation : 
 

1. Digital Versatile Disc (DVD), sometimes also known as Digital Video Disc (DVD), is an optical disc storage media format 
for storing digital data. 

2. DVD offers higher storage capacity than compact disc (CD) when having the same size. 

3. It is a digital optical dose storage format. It can be used for storing video, audio, images or data. 

 

Q :   
Performs simple math for CPU? 
(A) DIMM 

(B) BUS 

(C) ALU 

(D) Register 

Hide Answer 
 
Correct Answer : C 
 

Q :   
Information travels between the components of the motherboard through 
(A) Peripherals 

(B) Flash memory 

(C) CMOS 

(D) BUS 

Hide Answer 
 
Correct Answer : D 
 

Q :   
What is the process of dividing a disk into tracks and sectors? 
(A) Crashing 

(B) Tracking 

(C) Formatting 

(D) Dicing 

Hide Answer 
 
Correct Answer : C 
 

 
 
 
 
 



Q :   
File system is permanently stored in? 
(A) Device 

(B) Primary 

(C) Secondary 

(D) Direct Memory 

Hide Answer 
 
Correct Answer : C 
 

Q :   
Communication controls for the entire computer system? 
(A) Motherboard 

(B) Processor 

(C) Semi conductor 

(D) Coprocessor 

Hide Answer 
 
Correct Answer : A 
 

Q :   
What is DVD? 
(A) Digital Versatile Disc 

(B) Digital Video Disc 

(C) Dynamic Video Disc 

(D) Dynamic Versatile Disk 

Hide Answer 
 
Correct Answer : B 
Explanation : 
 

1. Digital Versatile Disc (DVD), sometimes also known as Digital Video Disc (DVD), is an optical disc storage media format 
for storing digital data. 

2. DVD offers higher storage capacity than compact disc (CD) when having the same size. 

3. It is a digital optical dose storage format. It can be used for storing video, audio, images or data. 

 
 
 
 
 
 
 
 
 



Q :   
Which of the following is not an OS? 
(A) DOS 

(B) MUS 

(C) UNIX 

(D) None of the above 

Hide Answer 
 
Correct Answer : B 
Explanation : 
 
"MUS" is not a recognized operating system abbreviation in common use. Operating systems are software programs that manage 
computer hardware and provide services for computer programs. Examples of well-known operating systems include Windows, macOS, 
Linux, and Unix. "MUS" does not correspond to any widely used operating system. 

 
Q :   
Which cobble is used to send modulated light? 
(A) Category 3 UTP 

(B) Category 5 UTP 

(C) fiber 

(D) coax 

Hide Answer 
 
Correct Answer : C 
Explanation : 
It seems there might be a confusion in your question. If you are referring to the technology used for transmitting data using modulated 
light, the term you are looking for is "fiber optic cable" or simply "fiber." Fiber optic cables are thin, flexible strands of glass or plastic 
that transmit data as modulated light pulses. They are widely used for high-speed data transmission over long distances due to their 
ability to carry large amounts of data with low attenuation and high bandwidth capabilities. 
 

 

Q :   
Computer language FORTRAN is useful in which field? 
(A) business 

(B) Drawing 

(C) Science 

(D) Commerce 

Hide Answer 



 
Correct Answer : C 
Explanation : 
 
FORTRAN (short for "Formula Translation") is a high-level programming language that is particularly well-suited for scientific and 
engineering applications. It was developed for numeric and scientific computing and is widely used in fields such as physics, 
engineering, mathematics, and other scientific disciplines. FORTRAN allows for efficient processing of mathematical and scientific 
computations, making it a popular choice for complex scientific simulations, mathematical modeling, and computational research. 

 

Q :   
Which is the fastest printer? 
(A) Laser Printer 

(B) Jet printer 

(C) Thermal Printer 

(D) Daisy wheel printer 

Hide Answer 
 
Correct Answer : A 
Explanation : 
Laser printers are generally known for their speed and efficiency, making them one of the fastest 
types of printers available for everyday office use. They use laser technology to print text and 
images, which allows for high-speed printing without compromising print quality. Laser printers 
are especially well-suited for printing large volumes of text documents quickly and are 
commonly used in office environments where fast and high-quality printing is required. 
 
 
Q :   
What is the computer language COBOL useful for? 
(A) Professional work 

(B) Graphic work 

(C) Scientific work 

(D) none of these 

Hide Answer 
 
Correct Answer : A 
Explanation : 
COBOL (Common Business Oriented Language) is a high-level programming language 
primarily used for business, finance, and administrative systems within companies and 
governments. It is particularly useful for handling large-scale, data-centric applications in areas 
such as accounting, payroll, inventory management, and other business-related tasks. COBOL is 
known for its readability and ease of use, making it suitable for professionals working on 
applications that require extensive data processing and business logic. Despite being an older 



language, COBOL continues to be used in many legacy systems, especially in industries where 
stability and reliability are paramount. 
 
 
Q :   
Which language is called 'foundation stone' for teaching languages like FORTRAN, ALGOL, PASCAL etc.? 
(A) BASIC 

(B) COBOL 

(C) FORTRAN 

(D) none of these 

Hide Answer 
 
Correct Answer : A 
Explanation : 
The language considered the "foundation stone" for teaching languages like FORTRAN, 
ALGOL, PASCAL, and many others is ALGOL (Algorithmic Language). ALGOL was a 
significant early programming language that influenced the design of subsequent programming 
languages, providing important concepts and structures used in the development of languages 
like FORTRAN, PASCAL, and C. While BASIC is also a widely used beginner-friendly 
programming language, ALGOL had a substantial impact on the development of programming 
language theory and design. 
 
 
Q :   
What is the key combination to move down one paragraph in MS PowerPoint?  
(A) down arrow 

(B) shift+down arrow 

(C) ctrl+down arrow 

(D) Alt+Down Arrow 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 
Actually, in MS PowerPoint (and most other word processing applications), the key combination to move down one paragraph 
is "Enter". Pressing the "Enter" key moves the cursor to the next paragraph. If you want to move the cursor down one line within the 
same paragraph, you can use the "Down Arrow" key. There isn't a specific default key combination to move down one paragraph in 
PowerPoint; it's more about using the "Enter" key to start a new paragraph. 
 
 
 
 
 



Q :   
Which command is used to remove a table from the database in SQL? 
(A) DELETE TABLE 

(B) DROP TABLE 

(C) ERASE TABLE 

(D) UNATTACH TABLE 

Hide Answer 
 
Correct Answer : B 
Explanation : 
In SQL, the DROP TABLE command is used to remove a table from the database. When you 
execute DROP TABLE, it deletes the table along with all its data, indexes, triggers, constraints, 
and permissions. It should be used with caution as it permanently removes the table and all 
associated objects from the database. 
Q :   
What are the components of the Central Processing Unit? 
(A) Control Unit 

(B) Arithmetic Logic Unit 

(C) Memory 

(D) All of the above 

Hide Answer 
 
Correct Answer : D 
 

Q :   
Red triangle at the top right corner of a cell indicates that _________ . 
(A) There is an error in the cell 

(B) The cell can't accept formula 

(C) The cell color is blue 

(D) There is an error in the text 

(E) There is a comment associated with the cell 

Hide Answer 
 
Correct Answer : E 
 

 
 
 
 
 
 
 



Q :   
Which of the following are part of the Logical Operations of the computer? 
(A) Addition 

(B) Greater than 

(C) Subtraction 

(D) Differentials 

(E) None of these 

Hide Answer 
 
Correct Answer : B 
 

Q :   
Which part of the computer carries out the arithmetic and logical operations? 
(A) Control Unit 

(B) Processing Unit 

(C) BIOS 

(D) Mother Board 

(E) None of these 

Hide Answer 
 
Correct Answer : B 
 

Q :   
Which of the following is the processing unit of the computer? 
(A) CPU 

(B) Memory 

(C) Graphic Card 

(D) Mother Board 

Hide Answer 
 
Correct Answer : A 
 

Q :   
News websites deliver customized ‘feeds’ of content to their readers via RSS, which stands for : 
(A) Really Simple Syndication 

(B) Real Social Syndication 

(C) Registered Subscriber Syndication 

(D) Really Simple Synchronization 

(E) None of these 



Hide Answer 
 
Correct Answer : A 
 

Q :   
What do we call a storage device where the access time is effectively independent of the location of the data? 
(A) Direct Access Storage Device 

(B) Secondary Storage Device 

(C) Primary Storage Device 

(D) Gateway Device 

(E) None of these 

Hide Answer 
 
Correct Answer : A 
 

Q :   
The terms “push and pull services” in context with the Banking are used in which among the following generally?  
(A) Rural Banking 

(B) Unit Banking 

(C) Mobile Banking 

(D) Online banking 

(E) None of these 

Hide Answer 
 
Correct Answer : C 

Q :   
Of the units mentioned in the options, which one is the largest as compared to the others? 

(A) Mega Bytes (MB) 

(B) Bytes (B) 

(C) Tera Bytes (TB) 

(D) Giga Bytes (GB) 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 

1. Among the options, terabyte represents the largest amount of data. 

2. Computer memory is usually measured in bytes. 

3. The storage capacity of a hard disk is measured in megabytes, gigabytes and terabytes. 

 



Q :   
What is the full name of PC? 
(A) Public Computer 

(B) Personal Computer 

(C) Private Computer 

(D) both (B) and (C) 

Hide Answer 
 
Correct Answer : B 
 

Q :   
DVD is an example of? 
(A) Output device 

(B) Hard Disk 

(C) optical disc 

(D) object disc 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 

1. Digital Versatile Disc (DVD), sometimes also known as Digital Video Disc (DVD), is an optical disc storage media format 
for storing digital data. 

2. DVD offers higher storage capacity than compact disc (CD) when having the same size. 

3. It is a digital optical dose storage format. It can be used for storing video, audio, images or data. 

 

Q :   
Performs simple math for CPU? 
(A) DIMM 

(B) BUS 

(C) ALU 

(D) Register 

Hide Answer 
 
Correct Answer : C 
 

 
 
 
 
 
 



Q :   
Information travels between the components of the motherboard through 
(A) Peripherals 

(B) Flash memory 

(C) CMOS 

(D) BUS 

Hide Answer 
 
Correct Answer : D 
 

Q :   
What is the process of dividing a disk into tracks and sectors? 
(A) Crashing 

(B) Tracking 

(C) Formatting 

(D) Dicing 

Hide Answer 
 
Correct Answer : C 
 

Q :   
Which of the following is an example of an optical disc? 
(A) Magnetic Disc 

(B) Memory Disk 

(C) Digital Versatile Disc 

(D) All these 

Hide Answer 
 
Correct Answer : C 
 

Q :   
What is DVD? 
(A) Digital Versatile Disc 

(B) Digital Video Disc 

(C) Dynamic Video Disc 

(D) Dynamic Versatile Disk 

Hide Answer 
 
Correct Answer : B 
Explanation : 
 



1. Digital Versatile Disc (DVD), sometimes also known as Digital Video Disc (DVD), is an optical disc storage media format 
for storing digital data. 

2. DVD offers higher storage capacity than compact disc (CD) when having the same size. 

3. It is a digital optical dose storage format. It can be used for storing video, audio, images or data. 

 

Q :   
Communication controls for the entire computer system? 
(A) Motherboard 

(B) Processor 

(C) Semi conductor 

(D) coprocessor 

Hide Answer 
 
Correct Answer : A 
 

Q :   
File system is permanently stored in? 
(A) Device 

(B) Primary 

(C) Secondary 

(D) Direct Memory 

Hide Answer 
 
Correct Answer : C 

Q :   
In which tab of MS Word 2010 Header and Footer option is available? 
(A) Insert Tab 

(B) View Tab 

(C) Page Layout Tab 

(D) Print Layout Tab 

Hide Answer 
 
Correct Answer : A 
Explanation : 
 

Header and Footer options are available in the Insert tab of MS Word 2010. On the Insert tab, the Header and Footer 
options are found in the Headers and Footer group. 

 

 
 
 



Q :   
Which of the following is a valid example of an e-wallet? 
(A) Drop Box 

(B) Way To Sms 

(C) Monster India 

(D) Pay TM (PayTM) 

Hide Answer 
 
Correct Answer : D 
Explanation : 
 

1. Paytm is an example of a valid e-wallet. E-wallet is a digital wallet that can be used to make payments both online and 
offline. 

2. Paytm is a popular Indian e-wallet used by millions of people in India. Paytm can be used by users for online shopping, 
cash transfers, and bill payments. 

Examples of valid e-wallets include- 

Google Pay 

PhonePe 

Amazon Pay 

Flipkart Pay 

Mobikwik 

Airtel Payments Bank 

ICICI Pockets 

HDFC Payzapp 

 

Q :   
The Internet is an example of a search engine. 
(A) Windows 

(B) Linux 

(C) Yahoo 

(D) M.S. Word (MS Word) 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 

The search engine performs the following tasks- 

1. Web crawling: Search engines search all web pages on the web using a crawler. A crawler is a program that finds new 
web pages by following links on the web. 



2. Indexing: Once the crawler finds all the web pages, the search engine indexes them in a database. The index contains 
information for each web page, such as title, URL, and content. 

3. Searching: When a user types a search query, the search engine searches all the web pages in the index that may be 
related to the query. 

 

Q :   
Which of the following memory device is similar to Cache Memory mainly in terms of speed? 
(A) Flash memory 

(B) D. RAM (DRAM) 

(C) S. RAM 

(D) E.E.P. ROM (EEPROM) 

Hide Answer 
 
Correct Answer : A 
Explanation : 
 

1. Flash memory is a portable storage device that can store data for a short period of time. 

2. Unlike traditional hard drives, flash memory is capable of retaining data even after the power is turned off. 

3. A flash drive is a small, portable flash memory card that plugs into a computer's USB port and acts as a portable hard 
drive. 

4. A flash drive is a portable data storage device. Flash drives contain multiple flash chips, which are large memory 
modules. 

 

Q :   
M.S. Which data types cannot be changed by the user in Access 2010? Choose the most appropriate option. 
(A) Auto Text 

(B) Date/Time 

(C) Auto Number 

(D) All of the Above 

Hide Answer 
 
Correct Answer : D 
Explanation : 
 

In MS Access 2010, data types cannot be entered or changed by the user. 

- Auto Text 

- Date/Time 

- Auto Number 

 



Q :   
Internet banking today uses ______ which, apart from using a secure website, sends a credential sent to the 
customer's registered mobile number as an additional security factor to make the transaction more secure. 
(A) Open Transaction Password 

(B) Open time password 

(C) One-Time Password 

(D) PDF 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 

1. The full form of OTP is One one-time password. 

2. OTP is used as one of the additional security features for secure online transactions. 

3. The OTP feature prevents certain types of identity theft by ensuring that a captured username/password pair cannot be 
used a second time. 

4. The user's login name usually remains the same, and the one-time password changes with each login. 

5. One-Time Password (aka One-Time Passcode) is a form of strong authentication, providing better security to eBanking, 
corporate networks, and other sensitive data systems. 

 

Q :   
With the help of which of the following keys you can delete the letters on the right side of the cursor? 
(A) End 

(B) Backspace 

(C) Delete 

(D) Home 

Hide Answer 
 
Correct Answer : C 
 

Q :   
What is the complete form of E-Mitra? 
(A) Employer Mitra 

(B) Emergency Mitra 

(C) Electronic Mitra 

(D) None Of The Above 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 



Application for Government Services and Fee Payment: Using the e-Mitra portal, citizens can apply for various government 
services and pay fees. These services include- 

- Bill payment Home 

- Application for certificates 

- Filing of grievances 

- Birth certificate 

- Death certificate 

- Caste certificate 

- Basic address proof 

- Ration card 

- Passport 

- driving license 

 

Q :   
Examples of social networking sites are? 
(A) Facebook 

(B) Twitter 

(C) Instagram 

(D) all of the above 

Hide Answer 
 
Correct Answer : D 
Explanation : 
 

Examples of social networking sites are. 

Facebook 

Twitter 

Instagram 

Google+ 

WhatsApp 

Quora 

LinkedIn 

Pinterest 

Snapchat 

MySpace 



Telegram 

WeChat 

Flickr 

Meetup 

Q :   
Ink-jet printers or band printers are classified

(A) Character Printers 

(B) Ink Printers 

(C) Line Printers 

(D) Off-Band Printers 

Hide Answer 
 
Correct Answer : A 
Explanation : 
 

Ink-jet printers or band printers are classified based on the p

 

Q :   
Which of the following is mandatory

(A) Body 

(B) Sender Mail ID 

(C) Attachment 

(D) Subject 

Hide Answer 
 
Correct Answer : B 
Explanation : 
 

1. To send an email, the sender's email address is mandatory. An email address is a unique identifier that connects an email 
message to a specific user. 

classified as – 

jet printers or band printers are classified based on the printing method. 

 

mandatory for sending an email? 

1. To send an email, the sender's email address is mandatory. An email address is a unique identifier that connects an email 1. To send an email, the sender's email address is mandatory. An email address is a unique identifier that connects an email 



2. Other required information for sending the email includes- 

- Recipient's Email Address 

- The subject of the email 

- Email Message 

Q :   
What is Web Browser? 
(A) Spider 

(B) A computer that stores files 

(C) A person who likes to visit websites 

(D) A software program that allows you to access sites on the World Wide Web 

Hide Answer 
 
Correct Answer : D 
 

Q :   
Which is not a type of secondary memory? 
(A) Solid State Drive 

(B) Hard Disk 

(C) Random Access Memory 

(D) USB Pen Drive 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 

Type of secondary memory. 

Solid State Drive 

Hard Disk 

USB Pen Drive 

 

Q :   
The main memory of the computer is called? 
(A) Primary Memory 

(B) Internal memory 

(C) Primary Storage 

(D) All these 

Hide Answer 



 
Correct Answer : D 
 

Q :   
Which data transport medium has the highest data transfer rate? 
(A) Twisted Cable 

(B) Co-Axial Cable 

(C) Optical Fiber 

(D) None of these 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 

1. Optical fibres use total internal reflection to transfer data. The primary condition for total internal reflection is that the 
signal must travel from an optically denser medium to an optically rarer medium. Secondly, the angle of incidence must be 
greater than the critical angle. 

 

Q :   
Which things are used together to add duplicate slides in the presentation of PowerPoint? 
(A) Ctrl + X 

(B) Ctrl + N 

(C) Ctrl + M 

(D) Ctrl + Z 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 

1. In MS PowerPoint, CTRL+M is a shortcut key used to insert a blank slide after the currently selected slide. 

2. MS PowerPoint is a presentation program used to display data with the use of pictures, graphs, etc. in the form of slides. 

3. It was created by Robert Gaskins and Dennis Austin. 

 

Q :   
Which of the following is an example of a search engine? 
(A) Paytm 

(B) Google 

(C) Flipkart 

(D) none of the above 

Hide Answer 



 
Correct Answer : B 
 

Q :   
What is meant by Microsoft Office Picture Manager? 
(A) Basic photo management software 

(B) An application that helps in editing scanned documents. 

(C) A scanning and OCR application 

(D) None of these 

Hide Answer 
 
Correct Answer : A 
Explanation : 
 

1. Microsoft Office Picture Manager is a raster graphics editor introduced in Microsoft Office 2003 and included until Office 
2010. 

  2. Microsoft Office Picture Manager refers to the basic picture management software. 

Q :   
The main system board of the computer is called ____. 

(A) Motherboard 

(B) Processor 

(C) Microchip 

(D) None of these 

Hide Answer 
 
Correct Answer : A 
 

Q :   
Which of the following system components is the brain of a computer? 
(A) Circuit board 

(B) CPU 

(C) Memory 

(D) Network card 

Hide Answer 
 
Correct Answer : B 
 

 
 
 
 
 
 



Q :   
What is the built-in permanent memory in a computer called? 
(A) RAM 

(B) ROM 

(C) CPU 

(D) CD-ROM 

Hide Answer 
 
Correct Answer : B 
 

Q :   
Which of the following is the full form of NTFS? 
(A) New Tree File system 

(B) New Technology file system 

(C) New Table file system 

(D) Both B and C 

Hide Answer 
 
Correct Answer : B 
 

Q :   
Which of the following is not a hardware processing chip ? 
(A) Processing chip 

(B) printer 

(C) mouse 

(D) Java 

Hide Answer 
 
Correct Answer : D 
 

Q :   
The monitor of a computer is- 
(A) storage device 

(B) processing device 

(C) input device 

(D) output device 

Hide Answer 
 
Correct Answer : D 
 

 



Q :   
If you wish to extend the length of the network without having the signal degrade, you would use a ___. 
(A) Gateway 

(B) Router 

(C) Modem 

(D) Repeater 

(E) Resonator 

Hide Answer 
 
Correct Answer : D 
 

Q :   
A series of instructions that tells a computer what to do and how to do it is called a ______. 
(A) Program 

(B) Command 

(C) User response 

(D) Processor 

(E) None of these 

Hide Answer 
 
Correct Answer : A 
 

Q :   
Verification of a login name and password is known as_____. 
(A) Configuration 

(B) Accessibility 

(C) Authentication 

(D) logging in 

(E) None of these 

Hide Answer 
 
Correct Answer : C 

Q :   
If you add a recipient email address to the box of an email message, a copy of the message is sent to that recipient, and the 
recipient's name is not visible to other recipients of the message. 
(A) To 

(B) Cc 

(C) Bcc 

(D) Subject 



Hide Answer 
 
Correct Answer : C 
 

Q :   
What happens if you edit an image inserted on a power point? 
(A) The source file inserted does not change. 

(B) The source file that was inserted is changed. 

(C) When you save the presentation, the source file gets changed. 

(D) None of the above. 

Hide Answer 
 
Correct Answer : A 
 

Q :   
What is the use of Paste With Live Preview in MS Excel 2010? 
(A) It avoids repeated hits and trails and you can easily re-use the content preview. 

(B) It can repair all files and folders. 

(C) It is useful for computing unknown values. 

(D) No such preview is available in MS Excel 2010. 

Hide Answer 
 
Correct Answer : A 
 

Q :   
Which of the following is an example of a web browser? 
(A) Google 

(B) Apple 

(C) Mozilla Firefox 

(D) Microsoft 

Hide Answer 
 
Correct Answer : C 
Explanation : 
 

1. Web Browser: A browser is a software application that is used to locate, retrieve, and display information from web pages, 
images, videos, and other files. The browser contacts the web server and requests information and the web server sends 
the information to the web browser which displays the results on the computer. 

2. Examples of web browsers are- 

- Google Chrome 

- Mozilla Firefox 

-Apple Safari 



- Microsoft Edge 

-Opera 

 

Q :   
Ribbon in MS Word 2010 is a series of ……….? 
(A) Gates 

(B) Windows 

(C) Tabs 

(D) Doors 

 
Correct Answer : C 
 

Q :   
MS word 2010 has horizontal bar at the bottom, which has many options like page number, word count etc? 
(A) Title bar 

(B) Status bar 

(C) Board Bar 

(D) Heading Bar 

 
Correct Answer : B 
 

Q :   
……….. using keyboard keys to permanently delete a file/folder, it will also not be available in the Recycle Bin? 
(A) Ctrl + Shift 

(B) Shift + Esc 

(C) Ctrl + Alt 

(D) none of the above 

 
Correct Answer : D 
 

Q :   
Which folder provides temporary storage for the files and folders you want to delete? 
(A) calculator 

(B) Dustbin 

(C) Recycle Bin 

(D) New Folder 

 
Correct Answer : C 
 



Q :   
The process of copying a file to a CD/DVD is often called? 
(A) Storing 

(B) Burning 

(C) Pasting 

(D) Assembling 

 
Correct Answer : B 
Explanation : 
 

Copying files to a CD ROM is known as the burning process. 

1. The full form of CD ROM is Compact Disc Read Only Memory. It is a storage device that can contain data as well as 
media files. 

2. Burning is the process of copying media files like movies, pictures, etc. to a CD. 

3. Ripping is the process of copying media files from a CD to a computer. 

4. Zipping is the process that compresses a file into a folder to reduce the space used. 

5. Digitization is converting information into digital format. 

Q :   
Which key enables you to delete characters to the right of the cursor? 
(A) End 

(B) Backspace 

(C) Delete 

(D) Home 

 
 
Correct Answer : C 
 

Q :   
is used to create a web page? 
(A) HTTP 

(B) FTP 

(C) HTML 

(D) none of the above 

 
Correct Answer : C 
 

Q :   
In MS-Power Point, the shortcut key to start slide show from the current slide is used. 
(A) Shift + F5 



(B) Ctrl + F5 

(C) Ctrl + Shift + F5 

(D) none of the above 

 
Correct Answer : A 
 

Q :   
You can find thumbnails of all the slides in your presentation to easily rearrange them in……….? 
(A) Slide show view 

(B) Review 

(C) Animation View 

(D) Slide sorterview 

 
Correct Answer : D 
 

Q :   
Suppose a directory has sub directories and some files, what happens whenever you move that directory from one 
place to another? 
(A) Only the files inside the directory are transferred 

(B) Only the sub directories inside the directory are moved. 

(C) Directories are moved but source files are not transferred. 

(D) The files and sub directories inside the directory are moved. 

 
Correct Answer : D 
 

Q :   
. ……………… is a personal information manager, mainly used in email applications, and also includes calendar, 
task manager, note taking, magazine, web browsing? 
(A) MS Excel 

(B) MS Paint 

(C) MS Access 

(D) MS Outlook 

 
Correct Answer : D 
 

 
 
 
 
 
 
 



Q :   
Which of the following CPU is part of? 
(A) ALU, CU 

(B) ALU, Mouse 

(C) ALU, IC 

(D) CU, CU 

 
Correct Answer : A 
 

Q :   
……….. is used to send digital data over a telephone line? 
(A) Scanner 

(B) LAN 

(C) Modem 

(D) Pen drive 

 
Correct Answer : C 
 

Q :   
A utility used to reduce the number of fragmented files and improve access speed? 
(A) Disc light 

(B) Data Defragmator 

(C) non-refragmater 

(D) WPAN 

Hide Answer 
 
Correct Answer : B 
 

Q :   
Which printer prints one letter in one stroke? 
(A) plotter 

(B) Laser Printer 

(C) stop matrix printer 

(D) Line Printer 

Hide Answer 
 
Correct Answer : D 
 

 
 
 



Q :   
What is the number of 'Function Key' in the keyboard? 
(A) 16 

(B) 12 

(C) 19 

(D) 14 

 
Correct Answer : B 
 

Q :   
What is the full form of OCR? 
(A) Optical CPU Recognition 

(B) Optical Character Recognition 

(C) Optical Character Rendering 

(D) none of these 

 
Correct Answer : B 
 

Q :   
What is the pattern of printed lines on most of the products called? 
(A) Barcodes 

(B) Scanners 

(C) Prices 

(D) Code 

 
Correct Answer : A 
 

Q :   
Which keys are called Ctrl, Shift, and Alt? 
(A) Function 

(B) Modifier 

(C) alpha numeric 

(D) none of these 

 
Correct Answer : B 
 

 
 
 
 



Q :   
What makes it easier to play a game? 
(A) keyboard 

(B) Mouse 

(C) joystick 

(D) All these 

 
Correct Answer : C 
 

Q :   
Represents the work output in the memory of the computer? 
(A) Monitor 

(B) Printer 

(C) RAM 

(D) ROM 

 
Correct Answer : A 
 

Q :   
Who made the first computer mouse? 
(A) William English 

(B) Douglas Engelbert 

(C) Robert Jawaki 

(D) none of these 

 
 
Correct Answer : B 
 

Q :   
The input device used to get printed diagram in the computer is? 
(A) Mouse 

(B) Printer 

(C) keyboard 

(D) Scanner 

 
Correct Answer : D 
 

 
 
 
 



Q :   
How is the display size of a monitor measured? 
(A) Horizontally 

(B) Diagonally 

(C) Zig-Zag 

(D) vertically 

 
Correct Answer : B 

Q :   
Computer readable code consisting of bars or lines of different widths and lengths is called _______ 
(A) ASCII code 

(B) Magnetic code 

(C) OCR scanner 

(D) Bar code 

 
Correct Answer : D 
 

Q :   
__________ is a unique name that you give to a file of information. 
(A) Folder 

(B) File name 

(C) File name extension 

(D) Device letter 

 
Correct Answer : B 
 

Q :   
You use ____________ see the output. 
(A) Monitor 

(B) Keyboard 

(C) Mouse 

(D) Scanner 

 
Correct Answer : A 
 

 
 
 
 
 



Q :   
Hardware consists of devices that can translate data into a form that a computer can process. 
(A) App 

(B) Input 

(C) System 

(D) All of these 

 
Correct Answer : B 
 

Q :   
Which key, along with another 'key', is used to perform a Special particular task? 
(A) Function 

(B) Arrow 

(C) Space bar 

(D) Control 

 
 
Correct Answer : D 
 

Q :   
Which of the following is not classified as computer hardware? 
(A) Mouse 

(B) Monitor 

(C) Hard disk 

(D) DBMS 

 
Correct Answer : D 
 

Q :   
Which of the following is a volatile memory? 
(A) RAM 

(B) EPROM 

(C) Hard Disk 

(D) SSD 

 
 
Correct Answer : A 
 

 
 
 



Q :   
The resolution of a computer monitor is measured by____. 
(A) Number of pixels 

(B) Number of dots per inch 

(C) Glow 

(D) PPM 

 
Correct Answer : A 
 

Q :   
Which of these features is related to the mouse of the computer? 
(A) Printing device 

(B) Memory device 

(C) Output device 

(D) Pointing device 

 
Correct Answer : D 

Q :   
What is called data in computer? 
(A) to the sign 

(B) the number 

(C) given information 

(D) sign and numerical information 

 
 
Correct Answer : D 
 

Q :   
What is called information in computer? 
(A) data 

(B) numbers 

(C) Collected data 

(D) All these 

 
Correct Answer : C 
 

Q :   
Meaning of E.D.P? 
(A) Electronic data power 



(B) Electronic data personal 

(C) Electronic data part 

(D) Electronic data processing 

 
Correct Answer : D 
 

Q :   
 Whose speed is more between human mind and computer? 
(A) Computer 

(B) Human mind 

(C) Equal in both 

(D) None of these 

 
 
Correct Answer : B 
 

Q :   
The memory power of man is comparable to that of computer? 
(A) General 

(B) high 

(C) low 

(D) Average 

 
Correct Answer : A 
 

Q :   
What type of intelligence is given to the computer? 
(A) Human 

(B) Artificial 

(C) pure 

(D) Others 

 
Correct Answer : B 
 

 

Q :   
What is the capacity of computer? 
(A) Low 

(B) high 



(C) limited 

(D) Unlimited 

 
Correct Answer : C 
 

Q :   
What is the main component of CPU? 
(A) Control Unit 

(B) Memory 

(C) Arithmetic Logic Unit 

(D) All these 

 
Correct Answer : D 
 

Q :   
Input is converted into output? 
(A) Memory 

(B) CPU 

(C) Input and output 

(D) Peripherals 

 
 
Correct Answer: B 
 

Q :   
. ________ is an input device, which is used to save a person’s voice on a computer. 
(A) Speaker 

(B) Scanner 

(C) Microphone 

(D) Joystick 

 
 
Correct Answer : C 

Q :   
Which of the following is not a pointing input device ? 
(A) Track ball 

(B) Joystick 

(C) Digitizing tablet 

(D) Scanner 



 
Correct Answer : D 
 

Q :   
________ is an output device producing continuous lines of different colors. 
(A) Daisy Wheel Printer 

(B) Plotter 

(C) Drum Printer 

(D) Chain Printer 

 
 
Correct Answer : B 
 

Q :   
Which of the following is a hard copy output device? 
(A) Monitor 

(B) Laser Printer 

(C) Visual Display Terminal 

(D) Projector 

 
Correct Answer : B 
 

Q :   
_________ is an impact printer. 
(A) Thermal Printer 

(B) Dot Matrix 

(C) Inkjet Matrix 

(D) Laser Printer 

 
Correct Answer : B 
 

Q :   
Which dialog box open using the F12 key in MS Word? 
(A) Save as 

(B) Mail Merge Wizard 

(C) Insert table 

(D) Insert Picture 

 
Correct Answer : A 
 



 
 
 
 
Q :   
Which can be used for quick access to commonly used commands and tools? 
(A) status bar 

(B) Tool bar 

(C) Menu Bar 

(D) Title Bar 

 
Correct Answer : B 
 

Q :   
Home key used for 
(A) Moves the cursor beginning of the document 

(B) Moves the cursor beginning of the paragraph 

(C) Moves the cursor beginning of the screen 

(D) Moves the cursor beginning of the line 

 
Correct Answer : D 
 

 
 
Q :   
Which of the following is an output device? 
(A) OCR 

(B) Projector 

(C) Mouse 

(D) Web camera 

 
Correct Answer : B 
 

Q :   
In a typical desktop computer, which of the following memory size would be largest? 
(A) Cache 

(B) Hard Disk 

(C) RAM 

(D) Registers 



 
Correct Answer : B 
 

 
 
Q :   
What is the part of the CPU that performs logical operations called? 
(A) RAM 

(B) ALU 

(C) Motherboard 

(D) Registers 

 
Correct Answer : B 

Q :   
When using a Chrome Internet Browser, a method of saving web page addresses for quick access is: 
(A) Clear Cache 

(B) Bookmark 

(C) Proxy Setting 

(D) Delete History 

 
Correct Answer : B 
 

Q :   
The Key__________is used to make the internet browser window full Screen. 
(A) F8 

(B) F10 

(C) F11 

(D) F9 

 
 
Correct Answer : C 
 

Q :   
Which of the following is used to secretly browse in Google Chrome? 
(A) New Tab 

(B) New Window 

(C) New Incognito Window 

(D) Bookmark 

 
Correct Answer : C 
 



 
 
 
 
 
Q :   
Which one of the following is not an internet browser? 
(A) Microsoft Edge 

(B) Tinder 

(C) Mozilia Firbox 

(D) Internet Explore 

 
Correct Answer : B 
 

Q :   
Which of the following is the first screen to appear on the monitor after windows 10 is loaded? 
(A) File Folder 

(B) Desktop 

(C) Recycling Bin 

(D) Recently Added Screen 

 
Correct Answer : B 
 

Q :   
What is the input device used to scan a marked answer book of a multiple choice question paper? 
(A) OCR 

(B) OMR 

(C) MICR 

(D) Card Reader 

 
Correct Answer : B 

 


